Cloud providers outage

Incident Report for Highnote

Postmortem

On June 12th, 2025, Google Cloud Platform (GCP) experienced a significant service disruption. Further details regarding this incident are available on the GCP status page: https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

Separately, Cloudflare reported a major outage on the same day. While Highnote's services were not affected by this event, it did lead to confusion for some of our customers. Cloudflare has published a post-mortem on their blog: https://blog.cloudflare.com/cloudflare-service-outage-june-12-2025/

Posted Jun 16, 2025 - 22:08 PDT

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 16:32 PDT

Monitoring

Google has identified the root cause of the incident and has implemented mitigation. Transactions and applications are being processed, and we are continuing to monitor for additional impact.
Posted Jun 12, 2025 - 14:05 PDT

Update

Highnote API has elevated p90 latency and error rate has increased to 0.7%
Posted Jun 12, 2025 - 11:48 PDT

Identified

We are aware of a possible Google Cloud Platform and AWS outage and are investigating the impact on our services. Application and transaction processing may be impacted during this time. We will provide updates as we learn more.
Posted Jun 12, 2025 - 11:15 PDT