Reports being generated may be missing data. Transaction processing is not impacted.

Incident Report for Highnote

Resolved

This incident has been resolved.
Posted May 17, 2026 - 14:38 PDT

Investigating

We are currently investigating an issue that may be causing delays in reporting data.
Posted May 17, 2026 - 09:51 PDT