Issue impacting access to the Highnote Dashboard
Incident Report for Highnote
Resolved
An upstream issue with a third-party provider impacted access to the Highnote Dashboard from 3:57p EST - 4:15p EST.
Posted Oct 30, 2023 - 13:53 PDT
This incident affected: Dashboard.